Quite alarming...

oshawa

New member
Messages
2
Reactions
0
#1
This is the second time this has happened to my 2017 GLC300. The first time was about 6 months ago and it happened so fast i can barely explain the details. The second time was a couple of days ago and this time it lasted a good 2 mins. Backed my car out of the garage & the ATC dash light came on and started to flash. I put it in park & switched the car off. waited a min. or two & repeated start up procedure including switching off the stop/start button. The car again flashed the ATC light and wouldn't move when placed in gear. It seemed to lock the wheel(s) and didn't want to move. I switched off again, repeated same and it appeared to clear itself. 20 Secs. later i'm entering busy street and it does the exact same thing. I tried to turn around but it wouldn't move. Switched it off, played with the gear shift etc. and managed to get back to my driveway. It then did the exact same thing again so i left it in the driveway 'till the following morning. It was my intention to phone the dealer at that time and request he pick it up. Tried once more and it was fine, drove it around the block a few time and all was normal. I hate to imagine what might have happened in this occurred on a major highway. Once the dealer has established what's going on i will post it for general info. but if anyone has an opinion or has experienced the same it would be good to hear from you. Thanks.
 
OP
O

oshawa

New member
Messages
2
Reactions
0
Thread Starter #2
Would you not imagine that a software issue with a single 2017 GLC 300 would be common to all 2017 GLC 300's manufactured prior to my car being manufactured as well as those after 'till a software revision was found to be necessary & installed. What am I missing?. My issue was resolved by such a revision & why MB didn't advise me of this potential problem prior to my having this problem is beyond me. They must have known this as a software revision was on the shelf.........
 

Mercedes GLC Posts



Top